Why the mapview doesn't follow the direction I'm going, but stays locked to north?

Quick answer:



To change this setting, tap the compass icon in the upper right corner of the map view


If the compass icon doesn't seem to help and the map still stays locked to north, make sure you're not using the App in "Easy Mode"

Disable "Easy Mode" and then tap the compass icon to toggle the map lock to north on or off

- Left side menu -> Settings -> Display > "Easy mode" -> tap the slider and change it from green (ON) to grey (OFF)


If "Easy mode" is off (not in use) and the compass icon still doesn't release the mapview from being locked to north, see "More information" for how to proceed




More information:



Disable the "Easy Mode" function


- Open the application

- Tap lower left corner icon to open left side menu or swipe the screen from left to center

- Scroll the menu all the way down until you find "Settings"

- Tap "Settings" and select "Display"

- Tap the slider on "Easy mode" and change it from green (ON) to grey (OFF)

- Return to mapview and tap the upper right corner compass icon to toggle mapview lock to north ON or OFF


If "Easy mode" is set OFF and the compass icon still doesn't release the mapview from being locked to north


There are usually only 3 options left:


- Is the device's electronic compass is broken?
- Device electronic compass is not available?
- There is no electronic compass in the device?


Consult your device's own tech.support or if warranty is still valid for the device, then contact the retailer you've bought it from



You can also contact Traker Support or send us a ticket if you encounter some unexpected problems or error messages etc. so that we can give you more detailed instructions

Did you find it helpful? Yes No

Send feedback
Sorry we couldn't be helpful. Help us improve this article with your feedback.